Acorn Acorn 5

Selection Tools






Selection Basics


The selection tools allow you to isolate a specific area of your image and then work in that area without altering the other areas of the image.  Acorn gives you a handful of ways to make selections on your image including the rectangle, elliptical, freehand, polygonal, and magic wand selection tools.


The shortcut key for switching to a selection tool is shift - M.  Pressing shift - M multiple times will then cycle through all the selection tools.  To remove a selection, choose the menu item  Select ▸ Clear Selection, or use the shortcut ⌘D.


Acorn will remember your selection when you save your image.  If you have a selection, save your image as a .acorn file.  You can close your file and quit Acorn. When you re-open the image, your selection will still be there.


Screen Shot 2015-04-30 at 2.58.52 PM.png

selections1.pngselections2.pngselections3.pngselections4.pngselections5.png


The rectangle selection allows you to make rectangular selections and the elliptical selection tool allows you to make oval selections.  The freehand selection tool allows you to make freehand selections.  This is great if you have a selection that does not fit in a box or a square.  The polygonal selection tool allows you make odd selections, but by making multiple clicks.  You can finish off your selection with a double click.  


The magic wand selection tool will select areas of the same color that you clicked on.  You can adjust the tolerance (how close a color has to be to the one you clicked on) in the selection palette.  For a live adjustment of the magic wand tolerance, you can click on the color in your image and drag the magic wand on the canvas inwards (to decrease the tolerance) or outwards (to increase the tolerance).  



Quick Mask


Quick mask mode can be found under the Select ▸ Quick Mask menu item.  Quick mask mode is an additional way of making selections in Acorn, and can be combined with other selection tools such as the magic wand to refine a selection.  You can use the brush, eraser, and even filters when quick mask mode is enabled.  


When you enter quick mask mode, it helps to think of your selection as a virtual layer which happens to be either red tinted or clear.  Painting with the color white in quick mask mode removes the tinted color overlay.  Painting with black restores the color overlay.  Anywhere you paint with white is where your selection will be, and when you exit quick mask mode the clear overlay (which you painted with white) will change into a standard selection.  Toggle with keyboard shortcut 'q' to view your selections within and outside of quick mask. 


For more detailed information on how quick mask mode works, read this tutorial. 




Preset Selections, Selection Size, and Making Selections Fit Exact Dimensions


Acorn offers preset selection dimensions under Select ▸ Preset Selections.  If you want your selection a specific size that is not a preset, check out this video tutorial.   You can view the width and height of your selection in the inspector palette, as well as in the lower left hand corner of the status bar of the image's window.  The status bar also displays the x,y coordinates of the selection.




Feathering a Selection


The feather command will soften up the edges of your selection.  You can bring up the feather sheet from the  Select ▸ Feather menu item.  The higher the feather radius, the softer the edges of your selection will become.  


The image to the right was made by creating a circular selection, feathering with a radius of 40, going to Select ▸ Inverse, and then Edit ▸ Fill using white.  

selections6.jpg



View Selection Clipped Out vs. Marching Ants


There are two different ways to view your selection.  There is the traditional "Marching Ants".  The image to the right is showing "clipped out".  Clipped out shows the area outside of the selection with a darkly tinted transparency.


Is there an advantage to using one or the other?  Not really- but it turns out some folks really like the clipped out look, and others like the marching ants.  You can alternate between these two options via Select ▸ View Selection As or use shortcut ⌘\.

Screen Shot 2015-04-30 at 3.20.26 PM.png



Moving Selections


To move a rectangle or elliptical selection you are actively drawing, hold down on the space bar while dragging.  Let go of the space bar to continue adjusting the size and shape of your selection.


Once you have made a selection, you can move it around with the arrow keys or move tool.  In addition to this, you can hold down the ⌘ (command) key and Acorn will first cut out the selection and then move it around your image.  Letting go of ⌘ will then place your floating selection.


You can hold down ⌘ and ⌥ (option) when clicking and dragging (or while using the arrow keys), and Acorn will continually copy and place your selection each time you release your click.  Here is a video of it in action, using a screenshot of Acorn's preferences window: Command Option Move in Acorn. 




Rotating and Transforming Selections


To rotate and transform a selection, go to Layer ▸ Rotate and Transform.  

Scale and Rotate allows you to scale your selection keeping the aspect ratio intact via on-canvas controls, or via percentage in the inspector palette.  You can rotate your selection by dragging on the canvas, or setting the specific angle

in the palette.  


Free Transform allows you to scale your selection via on-canvas controls without regard to the aspect ratio.  You can rotate your selection by dragging on the canvas.  


Perspective Transform allows to you transform via handles located at each corner of a rectangle surrounding your selection.  Moving the handles independently creates the illusion of perspective.


Flip Layer Horizontal/Vertical will flip your selection horizontally or vertically.





Addition, Subtraction, and Intersection Modes


Screen Shot 2015-04-30 at 3.21.45 PM.png


There are four selection modes available in Acorn.  They include:  regular, addition, subtraction, and intersection modes.  


Addition - When two or more selections overlap, they will be joined together to create a single selection encompassing all areas of the original selections.


Subtraction - When you draw a selection over an existing selection, it will remove that area of the original selection.


Intersection - Where selections overlap, only the area of overlap will be retained as a selection.  


54a5292e-d317-43ba-8308-927d843a1c38-Screen Shot 2013-03-26 at 1.26.48 PM.acorn




Selection Tips & Keyboard Shortcuts


To draw a perfect circle (or square), hold down the shift key after you have started your selection.  


When in the process of creating an oval or a rectangular selection, you can press the spacebar to reposition the origin of the selection.


To grow a selection from the middle of where you clicked, press the option key after you have started your selection.


To bring back your last selection, choose the Select ▸ Reselect menu item. 


Double clicking a thumbnail in the layers list will make a selection out of that layer.


To add to a selection, hold down the shift key before you start your selection.  The selection cursor will change to include a plus sign.  


To delete from a selection, hold down the option key before you start your selection.  The selection cursor will change to include a minus sign.


If you have a fully vertical or horizontal selection, holding down the option key will turn the Image ▸ Trim to Edges menu item into “Trim Out Selection”.  Trim out selection deletes the current selection and squishes the two endpoints of your image together (bitmap layers only).


To convert the current selection into a layer mask, choose the Layer ▸ Add Layer Mask menu item when your selection is active.


Keyboard shortcuts for making selections from layers include holding down the command key while clicking on a layer in the layers list to make a selection based off using the layer image as a mask.  If you hold command and the shift key, the new mask will be added to an existing selection, command and option will subtract, command/shift/option will intersect.  


If you use the arrow keys with a selection (and a selection tool is active) and hold down the option key, Acorn will copy the selection in the direction you press with the keys, thus extending the selection by a pixel (or 10 if you also hold down the shift key).  



See also:  Selection Basics (video tutorial), Quick Mask, Quick Mask Basics (video tutorial), Selecting Basics