Acorn Acorn 5

Shape Editing & Viewing


shape_editing0.png


There are various options for modifying your shapes in Acorn.  The 'Shape Tools' documentation outlines a few of the basics of shape editing including how to select shapes, and give your shapes a stroke or fill.  Acorn also offers additional shape editing options in the 'Shape' menu item, and in the shape pop-over window which will be covered below.



Basic Shape Editing


Adding Shapes:  Click on the shape tool of the style of shape you want to add and then click and drag on the canvas to draw the shape.  


Deleting Shapes: To delete a shape, select the shape(s) then hit the delete key.  Pressing delete on a shape layer without anything selected will remove all the shapes in the layer.


Duplicating Shapes:  You can duplicate a selected shape by choosing Edit ▸ Copy and then Edit ▸ Paste.  Another option is to use Shape ▸ Duplicate Shape.  The copy will be placed right above the original shape.


Resizing Shapes: To resize a shape, select the shape then click and drag on its bounding box using the move tool.  Hold down the shift key as you are dragging on the bounding box to keep the aspect ratio of the shape intact.  Holding down the option key as you are dragging will resize the shape from the center.  If you know the exact shape dimensions you want, you can use the shape width/height fields in the inspector palette.  To resize multiple shapes at once, select the shapes. Use the move tool to drag on the outer bounding box encompassing all the shapes.  You will be prompted by a pop-up window to convert your shapes to Bézier shapes.  You can choose to 'Always Convert' to avoid seeing this window in the future or 'Convert' to have the prompt continue to appear.  


Adding Shape Layers:  To add a new shape layer you can right click on the layers list to bring up the contextual menu, or choose Layer ▸ New Shape Layer from the menu.  An additional method is to hold down the option and command keys while clicking the '+' button in the inspector palette.


Filters on Shapes:  You can use filters on shape layers.  The filter will be present on all shapes in that layer.


Copying Shape Styles:  To modify shapes to have the same style attributes (stroke/fill/color/drop shadow/etc) as another shape on the same layer, select the shape(s) you want to change.  Then hold down the option + command keys at the same time and click on the shape whose attributes you want to copy. 


Flipping Shapes:  To flip a shape, choose Shape ▸ Flip Vertically/Horizontally.  If you have multiple shapes selected and choose Flip Horizontal or Vertical, the flip point will be the center of the all the selected shapes.  


Rotating Multiple Shapes:  You can select multiple shapes and rotate them all at once. To rotate shapes around the center point of all the selected shapes, hover over a bounding box corner until the rotation arrows appear.  Click and drag on the canvas to rotate.  Hold down the shift key to constrain the rotation to 45° increments.  To rotate multiple shapes around their individual center axes, use the angle value field in the inspector palette.


Aligning Shapes:  To align multiple shapes on the same layer, select the shapes you wish to align and then choose one of the options under the Shape ▸ Align... menu item.  This option can also be accessed by control-clicking on the selected shapes.


Arranging Shapes:  Shape orders within a layer can be re-arranged by choosing the Shape ▸ Arrange menu item.  This option can also be accessed by control-clicking on a shape.





Shape Pop-Over Window


The shape pop-over window can be summoned by selecting a shape and hitting the back tick key (`), or by going to the View ▸ Quick Config Popover menu item. The pop-over will be placed wherever your cursor is currently located on the canvas.  The back tick key is located on the upper lefthand corner of the keyboard. To hide the window, hit the escape key.  


There are various options available in the window including the ability to change the selected shape's blending mode, the number of star points, and checkboxes to add or remove a fill, stroke, and anti-aliasing.


The path operations available in the pop-over include union, intersect, difference, and exclude.  Path operations are discussed in more detail below.


If your shape has a stroke, you can modify the appearance of its line join style.  There are 3 options: pointed, rounded, and bevel.  Pointed is the default stroke appearance.  If you currently have a corner radius on your shape, you cannot modify the shape's line joint style.


At the bottom of the shape pop-over window are the shape align options.  If you have two or more shapes selected, then these options will become available to you.  The choices include left, right, top, and bottom edge align, as well as horizontal and vertical align center, and horizontal and vertical distribute center.

Screen Shot 2015-07-13 at 10.28.24 AM.png

Untitled 2.acorn




Boolean Path Operations


Boolean operations in Acorn allow you to combine, subtract, intersect, and exclude two or more selected shapes in order to create different shapes.  These options can be found under the Shape... menu item, as well as in the shape pop-over window.  The style attributes of the top-most selected shape in the layer will be applied to the other shapes involved in the operation.  






Shape Viewing


Under the 'View' menu item you can choose 3 different options for viewing your shapes.  When you select View ▸ Draw Shape Outline, the stroke and fill of the shapes in the current shape layer will be hidden.  Acorn will create a simple outline of your shapes which can be very useful if you have a lot of shapes you need to manage, especially when zoomed in.   View ▸ Draw Shape Vectors presents your shapes as scaled vectors, and View ▸ Draw Shape Pixels is the standard view.   

Screen Shot 2015-05-07 at 11.06.41 AM.png

 Shape Outline View